Michigan-Sportsman.com banner

1 - 5 of 5 Posts

·
Registered
Joined
·
159 Posts
Discussion Starter #1
I have a NEF Huntsman ML with the Metrics Unlimited breech plug. Shooting Barnes Expanders with 90 grains BH 209 and CCI Magnum 209 shotshell primers. After firing, the primers are stuck in the plug. Should I lube the primer or the pocket of the plug? I was shooting 110 grains, dropped to 90 because primers stuck. It stopped when I first dropped to 90, now they're sticking again. I have to pry them out with a knife or needle nose pliers.
Also, the breech plug seems long on the primer end, I have to snap the breech closed when there's a primer in. Could this be the issue with the stuck primers?
Suggestions?
 

·
Registered
Joined
·
6,873 Posts
You are pressing the primer tight to the breech plug if you have to force the breech closed. Sounds like the wrong breech plug.
 

·
Registered
Joined
·
35,255 Posts
It sounds like at one point they were not sticking and now they are. It could be a couple of things.

Did you change primers? If not you need to clean the hard carbon building up in the primer pocket. Wiping it out will not remove it.
 
  • Like
Reactions: junkman

·
Registered
Joined
·
159 Posts
Discussion Starter #5
Thanks for the replies, guys. It's the correct breech plug and it's clean. I've only used the CCI magnum 209 shotshell primers since the switch to MU plug, BH 209 and Barnes Expanders. Without the o-ring in the plug, the breech closes freely. So I'll experiment with thinner o-rings if I can find them.
 
1 - 5 of 5 Posts
Top