Michigan Sportsman Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
7,757 Posts
Discussion Starter · #1 ·
I have a 5 year old Remington 700 model muzzy and have had problems with the trigger and safety. It seems when I have it on safety and than open the bolt to put in the cap close bolt get ready to fire and flip the safety off, the trigger makes a small click and basically will not let me fully pull the trigger and then when I try and move the safety to on it will not let me and the safety freezes. It is all resolved when I rebolt the action and then I can fire or move the safety to on. Anybody have this problem? Any ideas?
 

·
Registered
Joined
·
1,329 Posts
I had a similar problem with my 700 ML earlier this year and what it turned out to be was that the bolt was not completely cocking for some reason.
The first shot would be a misfire but after recocking it fired fine.
The remedy was to take the bolt apart and thoroughly clean the spring and polish the firing pin with fine steel wool and relubricate with light gun oil.
Also remember to clean out the firing pin channel in the bolt itself. A dremel tool with a wire brush did a great job and I've not had a problem since.
 

·
Registered
Joined
·
585 Posts
I had a similar problem. I used to just scrub the bolt in soapy hot water never taking it apart. The thing rusted up to the point the gun wouldn't fire. After taking it apart and getting all the rust off from everything and putting some oil on everything it works like a charm now.
 

·
Registered
Joined
·
229 Posts
I dont know if the 700 ML have the same problem as the 700s and model 7s, But Remington has an ongoing problem with the guns firing when the safety is switched to off.
Dangerous and scary as hell. I just had to have a brand new model 7 gone through by a factory authorized repair facility. Everyone be aware! (and I love remingtons, so this really is a disappointemnt)
 
1 - 6 of 6 Posts
Top