Michigan Sportsman Forum banner
1 - 9 of 9 Posts

·
Registered
Joined
·
11,535 Posts
Discussion Starter · #1 ·
I picked up an Etrex Legend @ Target a few months ago. Haven't used it very many times. Marked a few way points here and there...I've been waiting for winter to use it rabbit hunting and ice fishing, but I'm noticing now that on the navigation screen the arrow seems to be malfunctioning. Very disappointing. Has anyone else experience this?
 

·
Registered
Joined
·
428 Posts
I don't know if yours has the same problem I had (and it sounds different). Mine started acting up 6-7 months after I had it. The display would have light streaks across the screen. Then I banged it and it would go away and be OK. A few days later it repeated. I called Garmin, got a tech person very quick (now that's a plus!) and they were concerned. Said to send it back and they will fix it. OK, I paid a small mailing postage fee to send it in and 5 days later I get it back! They replaced some connector inside, glued it so it wouldn't happen again and charged zero! Said if it happens again, get a hold of them. I have never had such great service...
Since then it is perfect and an awesome rig. I use mine especially out west and in California with topo maps at the ranches and metro maps in the cities. (you can load both types at once as long as they don't cover the same areas). Call them and get it fixed while it's in warranty. You will be pleased.
 

·
Registered
Joined
·
876 Posts
Michigan Hunter, I was having the same exact problem with mine. Didn't start to act until i had it for about a year and 1/2.

Thanks for the info! ;)
 
1 - 9 of 9 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top