Michigan Sportsman Forum banner
1 - 4 of 4 Posts

·
Registered
Joined
·
34 Posts
Discussion Starter · #1 ·
So I recently picked up a 1970s or so 7.5hp sears ted Williams Tecumseh boat motor. Starts up fine, idles fine, switches into gear fine, but when I have it in gear if I put it past about 50% throttle it sometimes make a popping noise, but ultimately stalls out. Then it'll start back up and same problem. Runs fine when throttle isn't open as much, without stalling or anything. There is a knob on it that has a rich/lean setting. Haven't messed with that as I'm not entirely sure how that would affect the motor. Thanks in advance
 

·
Registered
Joined
·
34 Posts
Discussion Starter · #3 ·
Have not cleaned out the carb yet as this is the first time I've taken it out therefor noticing the problem. Runs fine out of the water but once it's in and has to push the boat it's different. Don't know much about motors at all but what I've read is the motor/carb on that is roughly the same as a chainsaw/weedwhacker motor(obviously bigger though) and that they're easy to clean out. But I don't even know how to clean it out. And the gas tank is directly on the motor.


Popping like that, especially as you increase the throttle is a sign of a lean condition. Adjusting the rich/lean knob to the rich side may correct it but have you cleaned the carb out? Is the fuel tank on the engine or use a remote tank with a hose?
 

·
Registered
Joined
·
34 Posts
Discussion Starter · #5 ·
Alright thanks. Will try that tomorrow. Heading into work
One thing I would do then is make sure the vent in the gas cap is clear and working, also disconnect the fuel line at the carb and make sure you've got fuel/gas flow to the carb. Some of those old timers had a petcock/fuel shut off at the tank that will have a wire screen filter on it inside the tank, those can get plugged up pretty easy and cause a restriction or even loss of fuel from the tank. I'd also recommend going over all the bolts and screws and make sure they're tight, you dont have to go hawg wild, just snug them up as over time the paper gaskets will shrink that could cause a vacuum leak that will result in a lean condition.
 

·
Registered
Joined
·
34 Posts
Discussion Starter · #7 ·
Have one one like that. Most likely its your crank seals are leaning you out. If they havnt been changed in 40 yrs.You can find some parts for it at Certified Parts Corp they bought up the inventory when they went out
Where are those located at? And just look for similar one when buying new ones or is there an exact seal I need?
 
1 - 4 of 4 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top